
Avaya Merlin Magix/Legend Integration Notes
Legend Rel 2.0 and above

Introduction
DUVOICE VM offers a complete integration with the Magix/Legend telephone system manufactured by Avaya 
Technologies.  This file gives basic information on integrating the DUVOICE VM with the Magix/Legend.  Refer 
to  the  MAGIX/LEGEND  SYSTEM  PROGRAMMING  book  (AT&T  COM-CODE  555-630-111)  for  more 
information.

Switch Hardware Required
Legend Release 2.0 or Above, Please see section in this document labeled; Optional telephone features and 
considerations.

The MAGIX/LEGEND Control Unit must be powered down in order to insert or remove any modules. On power 
up if using multiple cabinets you must power the cabinets from left to right giving approximately 20 sec in-
between each cabinet turn up.

Available Magix/Legend T/R Card. For Voice Mail Integration
• Legend 012 T/R  w/ Ring Generator – PEC 614949 or PEC 61459 
• Legend 0012 T/R  PEC 61387 or 61487 Requires Ring generator PEC 61388 or PEC 61498 
• Magix/Legend 016 T/R 
• Magix 016 ETR Last 6 jacks (top 6) can support T/R or ETR, but not at the same time. 
• It  is  recommended that  one of  the ports  on the T/R or ETR module be designated for  the modem into the 

DUVOICE VM system.  If no extensions are available, wire a trunk line to the modem using a TKM switch or like 
switch devise.

Telephone System Programming

• Assign the DUVOICE VM extensions to a the Calling Group.  Note:  For best performance of message 
lights and outdialing to pagers you may opt to exclude the last DUVOICE VM port from group 770. The 
MAGIX/LEGEND programming procedure is as follows: System 
Programming>Start>Extensions>More/PGup>Grp Calling>Members>  Dial Calling Group Ext no (770)   
>Enter>  Dial ext. no  .>Enter>Back>Back>Back  

• Set the Calling Group type to Integrated VMI.  The MAGIX/LEGEND programming procedure is as 
follows: System Programming>Start>Extensions>More/PG up>Grp Calling>More/PG up>Group Type>Dial 
Calling group. No. (770)>Integrated VMI>Enter

• Assign Stations to cover to VM .  The MAGIX/LEGEND programming procedure is as follows: then enter 
the extension number of every telephone that will have Voice Mail.

• Assign Coverage group to DuVoice Voicemail.  The MAGIX/LEGEND programming procedure is as 
follows: EXTENSIONS⇒PAGE UP⇒GRP CALLING⇒GRP COVERAGE⇒770↵⇒30↵.

• Station Coverage controls This Feature will allow coverage control per Station. Please note that the 
console station can override all extension coverage’s with the Cover Control feature in the night service 
programming. The MAGIX/LEGEND programming procedure is as follows: System 
Programming>Start>Extensions>Pg up/More>Pg up/More>Cover Delay>Group Cover>  enter extension   
number   >  Select number of rings (1-9  )>Enter     Note: If the station is using the Primary or secondary 
coverage feature then the total number of rings counting Primary+Secondary+Group will determine the 
actual total rings, this is only a factor if other extensions on the system have a cover button programmed 
on a station for the extension that you are programming.

•   Setting Line/Trunks disconnect.  The MAGIX/LEGEND programming procedure is as follows: : System 
Programming>Start>LinesTrunks>TT/LS Disc>LS Disconnect>   select Yes   > Enter   



Auto Attendant Answer Schedule

24 Hour Auto Attendant (Immediate) – Copper Pots lines 
• Assign  trunks  to  voice mail  group  (770)  The MAGIX/LEGEND programming  procedure  is  as  follows: 

System  Program>Start>Extensions>Pg  up/More>Grp  Calling>Line/Pool>  Enter  vm  group  number   
(770)  >  Enter line/pool #>  Enter   Note: If all trunks reside in same pool group (70) and you add one trunk 
(801) not the group, the Magix will auto add all trunks in the pool group.

24 Hour Auto Attendant (Immediate) – DID/PRI Trunks
• Renumber Vm calling group to match number sent from Telco,  for Example: If Telco sends 3 digits and 

555 is the digits sent on main number in that you want Immediate by VM 24/7.  The MAGIX/LEGEND 
programming procedure is as follows: System Program>Start>Sysrenumber>Single>GrpCalling>enter old 
group number (770)>enter new number (555)>Enter   this will send all callers directly to the group that 
matches the Digits sent to the Magix from your Telco provider. If using PRI services then you can make 
use of the PRI translations tables to alter the inbound digits.   – Please reference your Avaya Manual.

Day Delayed / Night Immediate Auto Attendant– Copper Pots Lines
• Assign Lines to calling group – By assigning line to a calling group that has no extensions as members will 

allow the trunks to forward to VM  on a delay. The MAGIX/LEGEND programming procedure is as follows: 
System Program>Start>Extensions>Pg up/More>Grp Calling>Line/Pool>  Enter non used group  >  Enter  

• Over flow calling group to VM group – Using the group overflow feature will allow for a calling group to 
overflow to another group by time or number.  The MAGIX/LEGEND programming procedure is as follows: 
System Program>Start> Extensions>Pg up/More>Grp Calling>overflow>  enter non used group  >enter VM   
group>enter>    Time  base   –(sets  the  number  of  seconds  before  overflow)>  number  base   –(sets  the   
number of callers in before overflow)   prompt base   –(leave as default NO)   

Note: if using time coverage only such a 4 rings, set the number base to 99 and use 6 seconds per ring 
in the time base.

• No Mail box to match Overflowed group number – With no mailbox created in the voicemail to match the 
calling group created will direct the callers to the main greeting.

Day Delayed / Night Immediate Auto Attendant - DID/PRI Trunks
This answer schedule has several different ways to configure. Note: if caller info comes to VM and no mailbox 
is present to match then the caller will be routed to the main greeting. 

Operator station answers calls during day 
• Match the desired extension to match the sent number from the Telco.- By numbering a station to match 

the sent number from the Telco will route callers as intercom calls to that station. 
• Desired extension can not have mailbox that matches its extension.- With no mailbox created to match the 

extension the DID/PRI call rings as intercom and will follow its coverage. If no mailbox is created to match 
then the caller will reach the main greeting.
Using primary cover buttons

• Match Extension number to the sent number from Telco and program primary/secondary cover buttons on 
stations – By numbering an extension (non Adjunct) to match the sent number from Telco and program 
coverage buttons on desired stations that are to pick up the calls. Also the use of General pickup (*9) 
buttons will keep the Cover free to allow multiple calls to be answered on a station.

• Place Adjunct in cover path  - Place the Extension the matches the number sent from the Telco in the 
Coverage path to VM ( 1-30)
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Hospitality room phone control

The Dv4/DV8 or Dv20xx and the Avaya Magix can control a Guest room’s access to outside trunks either 
automatically with the DV20xx-INN-CTI  (DuVoice part  number)  or manually using the Console Phone and 
guest room phone. 

 
Manual Room Phone control
These applications are available and supported on the Magix rel 2.1 and above. It allows for any employee at 
the main console phone to monitor room availability and control telephones out dialing permissions.  By 
turning on the hospitality mode and using a DSS panel connected to the console phone gives a visual 
indication of the status of a room (see status table below). 

Considerations and Constraints
Only the Console phone can change the extension status to 0 (occupied). Also rotary phones are not 

supported for room status changes such as room clean 

• Turn on hotel mode – program as follows. System Program>Start>Options >Ext Status>  Select   
Hotel>Enter.   Note: the PBX can not support both hospitality mode and supervisor mode together.

• Program Extension Status (ES) buttons on console following below chart.

Status Feature Table 

ES Status Magix Feature Status can be 
changed at

DSS Key 
indication Description

ES0 Fea 760 Console only No light Room is checked In and able to use the phone

ES1 Fea 761 room or 
console Flashing Room is checked out and ready for cleaning

ES2 Fea 762 room or 
console Light On Room is Checked out and Ready for new tenant

Operation Instructions 
To check in a Room: At console Press ES0 button + DSS Room number 
To check out a Room: At console press ES1 button + DSS Room number
To change room cleaning status: at console press ES2 + DSS Room number or from room pick up 
phone and dial *762

Automatic Room phone control- CTI 
Magix release 2.0 and higher / with DuVoice DV20xx-INN-CTI 
 
These application are available and supported on the Magix rel 2.1 and above. It allows for any employee at 
the main console phone to monitor room availability and control telephones out dialing permissions.  By 
turning on the hospitality mode and using the Dv20xx-INN-CTI. 

• DuVoice Document  IN000004 (Magix Integration with CTI Link)
• Hardware required :The CTI link requires 1 MLX port on the Magix 
• CTI Programming - programming is as follows: System Programming>Start>AuxEquipt>CTI LINK>  Enter   

MLX ext number  > Enter  
• Testing -  the  CTI  link  Status  on  the  Magix  is  as  follows  :  Maintenance>Port>Station>  Enter  MLX   

station/CTI ext  >Status    
  If CTI is up you will see: Physical Link: UP,

 If CTI in Down you will see : Physical Link : Down (note: this is usually due to connectivity problems, 
Check you cable pin outs as it should be straight thru.)
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Optional Telephone features

Record-A-Call
To complete this you will need technical bulletin TB000020

Explanation: To use record a call a second station or adjunct circuit is used that will forward to voicemail. To 
initiate this while on a call you conference in your adjunct circuits extension to the call, the adjunct will forward 
to the duvoice via a cover path. This will require you to alter the duvoice integration and choose a number plan 
for the adjunct that has on digit more than there actual extension for example: the users telephone extension 
is 500 and there adjunct is 1500 etc. you will also need to alter the duvoice integration file to accept the 1500 
extension as record a call for 500.  Please refer to TB TB000020 for explicit instructions. 

Music On-Hold 
• Connecting  an external  music  source  to  a  programmed Analog  trunk  Port  along  with a  Avaya MOH 

Coupler on the MAGIX/LEGEND will provide music while calls are on hold 
Programming  is  as  follows:  System  Program>Start>AuxEquip>MusicOnHold>  Dial  line/Trunk  no  >   
Enter>Back   (note: Entire PBX must be idle Before programming MOH) 

Direct Voice Mail Transfer Legend release 3.0 or above     (Feature 56) 
This feature allows any extension on the Magix/Legend to transfer  a caller directly into a mailbox without 
ringing the phone
• Using the VM Transfer Button followed by the Extension number of the mailbox that you wish to direct the 

caller to will immediately send the caller to the voice mailbox of the extension number that you entered. 
For transferring callers to a mailbox that does not have a physical extension on the system you will need to 
renumber  an  Adjunct/MFM circuit  (MLX TDL)to  match  the  mailbox number  and  add  the  renumbered 
adjunct into the cover path to voicemail.  

Trunk-to-Trunk / Off-Premise Transfers Legend release 4.0 or above 
This feature allows a voicemail port to transfer a caller to an outside number
• Trunk to trunk transfer permissions, programming is as follows System 

Program>Start>Extensions>More >More > Trunk Transfer>  Enter VM ext number  >ENTER   
• Restriction Permissions, programming is as follows   System Program>Start>Extensions>Restrictions> 

Enter VM extension number  >select either unrestricted or toll restricted> Enter   (note: toll restriction will 
NOT allow 1+number dialing)

• ARS Restriction  Permissions, programming is as follows   System program> Start> Extensions> ARS 
Restrict>   Enter VM extension number  >select ARS level equal to or high than out dialing pools ARS   
levels (note: ARS level of 3 will allow out dialing by Magix/Legend Defaults)

Message Waiting Indicators 
This feature will light the MWI indicator on your Telephone set 
• The Avaya Magix and Legend require that the station that has turned on the message waiting light must be 

the same one to turn it off. If the voice mail ports extension numbers are changed or moved around and 
Message indicators were turned on prior to the adjustment you must turn off the light at the phone that has 
the light turned on.   

Centralized Voice Messaging
One or more Merlin Legend systems Release 6.1 or later can share the DuVoice Messaging system via a T1 
type point to point tie. Please refer to the Avaya programming manual for programming instructions for the 
Avaya systems. 

Conclusion
If you need further assistance, please contact DuVoice Technical Support at (425) 250-2393 between the
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hours of 8am and 5pm (Pacific Time), Monday-Friday.
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